IonCube Loader is a tool, which is needed to run files which are protected with ionCube PHP Encoder. The latter is an application employed to make PHP code human unreadable, as a way to protect it from reverse engineering and not authorized use. A lot of script-driven applications, particularly discussion boards, content management systems and e-commerce solutions are protected with ionCube PHP Encoder, therefore when you buy a script and you find that ionCube is on the list of web hosting environment prerequisites, you need to ensure that your web hosting server has the instrument pre-installed. Though it's not that hard to set it up if you have your own server, it's almost impossible to do that on a shared hosting server as the PHP environment should be precompiled and all clients on the server will be affected.

IonCube in Shared Hosting

IonCube Loader is supplied with every single shared hosting package that we provide and you'll be able to activate it anytime with just a couple of clicks, so you can take advantage of script apps that require it. You'll be able to do that from the PHP Configuration area of your Hepsia Control Panel and all it'll take to enable or disable ionCube is to click a button. The change takes effect within a minute, which means that you're able to proceed and set up the application that you need without delay. The exact same section allows you to switch the PHP release that's active for your account, because we support a number of versions on our leading-edge cloud platform. In case you move to a version that you have not used so far, you will need to activate ionCube Loader again. Experienced users will be able to use a php.ini file in a specific domain folder so as to set a PHP release different from the one for the entire account or enable/disable ionCube Loader.

IonCube in Semi-dedicated Hosting

In case you purchase a semi-dedicated server plan from us, you will be able to take advantage of any kind of script-driven app that requires ionCube Loader due to the fact that the tool is available on all the servers that are part of our advanced cloud website hosting platform. Furthermore, we support various releases of PHP, so if you switch from PHP 4 to 5.2 or 5.3, for instance, you can activate ionCube for this particular release with only a click from your Hepsia Control Panel. Our platform will remember your choice, and if you move back to the previous release of PHP, the instrument will already be active. For more tech-savvy users, we also provide the option to select the PHP version and whether ionCube will be active or not for a specific domain without altering the settings for the whole hosting account. This is done by putting a php.ini file in a domain folder with a couple of lines of code.